Oldal: 1 / 3 123 UtolsóUtolsó
Eredmény: 1 - 10 (28) összesen

Téma: Karakterhiba

  1. #1
    Új tag
    Csatlakozott
    09-02-13
    Hozzászólás
    7
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás Karakterhiba

    Sziasztok!

    Teljesen zöldfülüként nekiláttam egy honlap készítésének. Az Easy Website Pro segítségével egészen pofásra sikeredik (még bőven benne vagyok a munkában) az oldal, de egy nagy problémám van. Néhány button felirata, amivel további al-oldalakat hívok meg, ékezetes betűket tartalmaz. A program saját preview-ában hibátlanul jelenik meg minden, de ha elmentem weblapként, vagy browserben nézem meg az előnézetet, az ékezetes betű, és a közvetlenül utána álló betű is egyszerűen hiányoznak. Nem ábra, nem kérdőjel van az ékezetes betű helyén, hanem simán lenyeli, illetve úgy néz ki, mintha semmit sem állna ott.
    Már sok mindent megpróbáltam, de mivel nem igazán értek hozzá, eddig terjedt a tudományom. Ha valaki tud segíteni, megköszönöm, de kérem, úgy fogalmazza meg az útmutatót, hogy én csak a kályhától tudok elindulni. :-)
    Köszönöm előre is!



  2. #2
    insert_click bubu001 logója
    Csatlakozott
    08-05-19
    Hely
    Budapest
    Hozzászólás
    1.296
    Begyűjtött 7 köszönetet
    5 hozzászólásával

    Alapbeállítás re: Karakterhiba

    Karakterkészlet mire van beállítva?
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2" />
    vagy utf legyen...



  3. #3
    Új tag
    Csatlakozott
    09-02-13
    Hozzászólás
    7
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Karakterhiba

    Idézet bubu001 eredeti hozzászólása Hozzászólás megtekintése
    Karakterkészlet mire van beállítva?
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2" />
    vagy utf legyen...
    Alapból charset=utf-8 van beállítva. Így produlálja azt, hogy elnyeli az ékezetes betűket (nem csak a magyar hosszút, hanem mindent, az ö-t is pl). Átállítottam "charset=iso-8859-2"-re, akkor meg mindenféle jel jelenik meg az ékezetes betűk helyett.



  4. #4
    sbs
    sbs nem elérhető
    Google 'n' Roll Man sbs logója
    Csatlakozott
    08-07-03
    Hely
    Tárnok és Budapest
    Hozzászólás
    2.109
    Begyűjtött 3 köszönetet
    3 hozzászólásával

    Alapbeállítás re: Karakterhiba

    Próbálkozhatsz még ezzel:
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1250">

    de lehet hogy az Easy Website Pro-ban van valami "csavar"
    MIndenesetre ha csak egy notepad-al szerkeszted akkor is jónak kell lennie bármely karakterkódolást használod.

    Esetleg szétnézhetsz még a Windows területi beállítása között is.


    Ablak és beltéri ajtó :: Netmax: "Mindig van a tiédnél jobb oldal..." :: Építkezés Fórum

  5. #5
    Új tag
    Csatlakozott
    09-02-13
    Hozzászólás
    7
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Karakterhiba

    Idézet sbs eredeti hozzászólása Hozzászólás megtekintése
    Próbálkozhatsz még ezzel:
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1250">

    de lehet hogy az Easy Website Pro-ban van valami "csavar"
    MIndenesetre ha csak egy notepad-al szerkeszted akkor is jónak kell lennie bármely karakterkódolást használod.

    Esetleg szétnézhetsz még a Windows területi beállítása között is.
    Köszi, ez múködött. Az utf-8 helyett a windows-1250 van a fájlban, és láss csodát: a betűk helyesen jelennek meg... de! A honlap elején, a bal felső felső sarokban egy oda nem tartozó, 3 karakterből álló szöveg jelent meg: egy ékezetes d (d') betű, egy dupla nyíl, és egy ékezetes z (ż). ... Mi a teendő???



  6. #6
    Rubyist Geri logója
    Csatlakozott
    07-12-15
    Hely
    \x90
    Hozzászólás
    5.608
    Begyűjtött 1.334 köszönetet
    829 hozzászólásával

    Alapbeállítás re: Karakterhiba

    nyisd meg a fajlt jegyzettomb-el es mentsd el ujra. az a bom-signature



  7. #7
    Új tag
    Csatlakozott
    09-02-13
    Hozzászólás
    7
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Karakterhiba

    Idézet Geri07 eredeti hozzászólása Hozzászólás megtekintése
    nyisd meg a fajlt jegyzettomb-el es mentsd el ujra. az a bom-signature
    Jegyzettömbel írtam át a charset-értéket, de azért megpróbáltam újra megnyitni és menteni, nem segített, maradt a három karakter a lap tetején.



  8. #8
    Rubyist Geri logója
    Csatlakozott
    07-12-15
    Hely
    \x90
    Hozzászólás
    5.608
    Begyűjtött 1.334 köszönetet
    829 hozzászólásával

    Alapbeállítás re: Karakterhiba

    akkor csinald meg a kovetkezot:
    csinalsz egy biztonsagi masolatot, utana vagolapra rakod a kodt, megnyitsz egy jegyzettombot es beilleszted a kodot,a karakterkodolast pedig ird at utf-8-ra. ez a windows 1250 semmire sem jo


    If debugging is the process of removing software bugs, then programming must be the process of putting them in.
    Github Rake tutorial
    Give a man a fish and you feed him for a day. Teach a man to fish and you feed him for a lifetime.
    Respect all, fear none

  9. #9
    sbs
    sbs nem elérhető
    Google 'n' Roll Man sbs logója
    Csatlakozott
    08-07-03
    Hely
    Tárnok és Budapest
    Hozzászólás
    2.109
    Begyűjtött 3 köszönetet
    3 hozzászólásával

    Alapbeállítás re: Karakterhiba

    Valami hiba lehet ott a kódban amit szövegként érzékel és megjeleníti a böngésző. Tipikus esete a szintaktikai hibáknak.



  10. #10
    sbs
    sbs nem elérhető
    Google 'n' Roll Man sbs logója
    Csatlakozott
    08-07-03
    Hely
    Tárnok és Budapest
    Hozzászólás
    2.109
    Begyűjtött 3 köszönetet
    3 hozzászólásával

    Alapbeállítás re: Karakterhiba

    Idézet Geri07 eredeti hozzászólása Hozzászólás megtekintése
    ez a windows 1250 semmire sem jo
    Ha...ha...
    2525252525252525



Oldal: 1 / 3 123 UtolsóUtolsó

A téma címkéi:

Könyvjelzők

Hozzászólás szabályai

  • Új témákat nem hozhatsz létre
  • Válaszokat nem küldhetsz
  • Fájlokat nem csatolhatsz
  • A hozzászólásaidat nem módosíthatod
  •