Oldal: 3 / 12 ElsőElső 12345 ... UtolsóUtolsó
Eredmény: 21 - 30 (120) összesen

Téma: Ruby On Rails

  1. #21
    'Say Hello To My Little Friend'
    Csatlakozott
    09-07-09
    Hely
    Erdély.MArosvásárhely
    Hozzászólás
    2.072
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Ruby On Rails

    Idézet Djibouti eredeti hozzászólása Hozzászólás megtekintése
    Más kérdés:

    A Heroku-n hozzáadtam a sendgrid plugint. Kell az nekem egyáltalán egy egyszerű "kapcsolat" formhoz?
    Logikus módon Heroku-n nincs sendmail, mivel a sendmail az egy ilyen Linux/Unix/MacOSX dolog, és általában az usr/bin/sendmail-ben van. Ha meg egy cseles cloudon, vagy Windowson, vagy ilyesmin vagy, akkor nyilván nem tudod használni.

    Sendgridhez pedig, ha heroku addons:add-al adod hozzá, akkor az égvilágán nem kell csinálnod semmit. Az lesz az alapértelmezett delivery_method és kész.

    Ha meg csak 5%-át érted a Rails2-nek, akkor tényleg váltanod kellene 3-ra. Azok váltanak nehezen, akik napi nyolc órában Railset programoznak és berögzült a 2-es. De ha te most tanulod, akkor miért tanulnád meg a régit?



  2. #22
    Tag
    Csatlakozott
    10-02-07
    Hozzászólás
    69
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Ruby On Rails

    Köszi! Akkor ezt nem is kell beírnom sehova?
    Kód:
    ActionMailer::Base.smtp_settings = {
      :address        => "smtp.sendgrid.net",
      :port           => "25",
      :authentication => :plain,
      :user_name      => ENV['SENDGRID_USERNAME'],
      :password       => ENV['SENDGRID_PASSWORD'],
      :domain         => ENV['SENDGRID_DOMAIN'],
    }
    Nyilván helyettesítve a password és egyebek?

    Azért nem váltottam, mert az összes anyag megvan pdf-ben amit csak kiadtak a Rails-hez. Amit meg itthon meg lehetett venni azt megvettem. A 3-hoz sajnos még nincsenek ingyenes források (torrent).
    De tényleg most kéne váltanom. Amit eddig gányoltam az (Talán te írtad egyszer) csak .html.erb és nem .html. Ennyi benne a Rails.


    Utoljára módosítva: Djibouti által : 2010-09-19 15:27

  3. #23
    'Say Hello To My Little Friend'
    Csatlakozott
    09-07-09
    Hely
    Erdély.MArosvásárhely
    Hozzászólás
    2.072
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Ruby On Rails

    Idézet Djibouti eredeti hozzászólása Hozzászólás megtekintése
    Köszi! Akkor ezt nem is kell beírnom sehova?
    „In case you’re not using it with Rails, it must be configured like:”
    Szóval nem, ez akkor kell, ha NEM Rails-el használod a Sendgridet. Tehát minden más esetben kell egy ilyesmi. De te pont, hogy Railssel akarod használni. Akkor meg semmit nem kell csinálni az égvilágon miután hozzáadtad. A Rails okos és tudni fogja, hogy nem viccből adtad hozzá a Sendgridet a Herokuhoz, hanem azért, mert emaileket akarsz küldeni vele. Ennyi pont elég is. Ha más programozási tapasztalatokkal fogsz neki a Railsnek furcsa lehet, hogy a Rails KISS alapelvre épül. Ha valami egyértelmű, akkor azt nem kell leírni.



  4. #24
    Tag
    Csatlakozott
    10-02-07
    Hozzászólás
    69
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Ruby On Rails

    Storno!

    Hogy tudok upgradelni 3-ra?



  5. #25
    'Say Hello To My Little Friend'
    Csatlakozott
    09-07-09
    Hely
    Erdély.MArosvásárhely
    Hozzászólás
    2.072
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Ruby On Rails

    Idézet Djibouti eredeti hozzászólása Hozzászólás megtekintése
    Storno!

    Hogy tudok upgradelni 3-ra?
    Herokun az összes verzió elérhető.
    Bárhol máshol:
    Kód:
    gem install rails
    Ez azt eredményezi, hogy a legújabb stable rails gem települ, jelesül 3.0.0



  6. #26
    Tag
    Csatlakozott
    10-02-07
    Hozzászólás
    69
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Ruby On Rails

    OK! Elkezdte a terminál telepíteni. A régit nem kellett volna lepucolni?
    Kód:
    Successfully installed activesupport-3.0.0
    Successfully installed i18n-0.4.1
    Successfully installed activemodel-3.0.0
    Successfully installed rack-test-0.5.4
    Successfully installed rack-mount-0.6.13
    Successfully installed tzinfo-0.3.23
    Successfully installed abstract-1.0.0
    Successfully installed erubis-2.6.6
    Successfully installed actionpack-3.0.0
    Successfully installed arel-1.0.1
    Successfully installed activerecord-3.0.0
    Successfully installed activeresource-3.0.0
    Successfully installed polyglot-0.3.1
    Successfully installed treetop-1.4.8
    Successfully installed mail-2.2.6.1
    Successfully installed actionmailer-3.0.0
    Successfully installed thor-0.14.1
    Successfully installed railties-3.0.0
    Successfully installed bundler-1.0.0
    Successfully installed rails-3.0.0
    20 gems installed
    Installing ri documentation for activesupport-3.0.0...
    Installing ri documentation for i18n-0.4.1...
    Installing ri documentation for activemodel-3.0.0...
    Installing ri documentation for rack-test-0.5.4...
    Installing ri documentation for rack-mount-0.6.13...
    Installing ri documentation for tzinfo-0.3.23...
    Installing ri documentation for abstract-1.0.0...
    Installing ri documentation for erubis-2.6.6...
    Installing ri documentation for actionpack-3.0.0...
    Installing ri documentation for arel-1.0.1...
    Installing ri documentation for activerecord-3.0.0...
    Installing ri documentation for activeresource-3.0.0...
    Installing ri documentation for polyglot-0.3.1...
    Installing ri documentation for treetop-1.4.8...
    Installing ri documentation for mail-2.2.6.1...
    Installing ri documentation for actionmailer-3.0.0...
    Installing ri documentation for thor-0.14.1...
    Installing ri documentation for railties-3.0.0...
    Installing ri documentation for bundler-1.0.0...
    Installing ri documentation for rails-3.0.0...
    ERROR:  While executing gem ... (Errno::ENOENT)
        No such file or directory - lib
    A végén ezt a hibaüzenetet komolyan kell venni?

    Update:

    Kód:
    rails -v
    
        Rails 3 doesn't officially support Ruby 1.9.1 since recent stable
        releases have segfaulted the test suite. Please upgrade to Ruby 1.9.2
        before Rails 3 is released!
    
        You're running
          ruby 1.9.1p378 (2010-01-10 revision 26273) [i686-linux]
    
    Rails 3.0.0
    Ezt nem mondtad!


    Utoljára módosítva: Djibouti által : 2010-09-19 15:58

  7. #27
    'Say Hello To My Little Friend'
    Csatlakozott
    09-07-09
    Hely
    Erdély.MArosvásárhely
    Hozzászólás
    2.072
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Ruby On Rails

    E nem Windows, hogy format c: /u -val indul a telepítés. Nem bántják egymást.
    De ha gondolod gem uninstall rails és válaszd ki amelyik verzió nem kell.

    Ami még jó: gem update --system

    Esetleg tegyél más Ruby-t is, mondjuk 1.9.2-t, ha nem az van. Ez viszont már oprendszer függő. Rails 3 megy 1.9.2 vagy 1.8.7-el, de 1.9.1-el van egy hülye segfault bug.

    Szóval:
    1. Tegyél Ruby 1.9.2-t
    2. gem update --system
    3. gem install rails

    Honnan tudhattam volna, hogy pont Ruby 1.9.1-esed van?


    Utoljára módosítva: WSzP által : 2010-09-19 16:01

  8. #28
    Tag
    Csatlakozott
    10-02-07
    Hozzászólás
    69
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Ruby On Rails

    Szerinted én tudtam? Úgy nézek ki?
    A régi Ruby le kell gyalulni??



  9. #29
    'Say Hello To My Little Friend'
    Csatlakozott
    09-07-09
    Hely
    Erdély.MArosvásárhely
    Hozzászólás
    2.072
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Ruby On Rails

    Ha van RVM _http://rvm.beginrescueend.com/ akkor megfér két Ruby, ha nem, akkor csak egy maradhat, de az lehet upgrade.
    Szerintem az lenne a legjobb, ha upgradelnéd az 1.9.1-et.



  10. #30
    Tag
    Csatlakozott
    10-02-07
    Hozzászólás
    69
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Ruby On Rails

    Jó jó! De még fél szavakból nem értjük meg egymást.
    Milyen paranccsal kell upgradelni?



Oldal: 3 / 12 ElsőElső 12345 ... UtolsóUtolsó

A téma címkéi:

Könyvjelzők

Hozzászólás szabályai

  • Új témákat nem hozhatsz létre
  • Válaszokat nem küldhetsz
  • Fájlokat nem csatolhatsz
  • A hozzászólásaidat nem módosíthatod
  •