Eredmény: 1 - 7 (7) összesen

Téma: css gond

  1. #1
    Mentor Zaphod logója
    Csatlakozott
    08-01-21
    Hely
    Veszprém
    Hozzászólás
    324
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás css gond

    Talán már más is találkozott az a kérdéses problémával és talán a megoldás mindenki használra lehet, tehát leírom.

    Több alkalommal előfordul mostanság nálam, hogy az IE7, mintha nem töltené be a css-t, illetve egyes részeit.

    Konkértan.

    body { margin-top:5px; margin-left: 10%;
    color: #000; background: url(images/bg.gif); font-family:Arial;}

    mikor indítom az oldalt, minden rendben, de ha váltok tartalmat (másik menüpont) akkor ez a rész NEM hajtódik végre, csak F5-re. Itt is elég zavaró, a left margin hiánya miatt, de pl. ha a background nem egy kép, és nem fehér, akkor elég gáz a megjelenés. Még konkrétabban.

    body { color: #000; font-family: Arial; font-size: 12px;
    margin: 0px; text-align:center; background:#03412c; }

    ez a kertamiszep.hu oldalon van és szemmel láthatóan az IE7 sokkal később hajtja végre, mint a kód többi részét. Betölti a lapot, majd olyan 1/2mp-el később beszínezi a hátteret és elteszi a helyére a lapot. Eddig a háttérszínt be sem töltötte, csak F5-re. Igazából nem tudom hogy mi történt, de ez már javulás

    Tökmindegy, hogy milyen szintaktikával írom be, a 7-es IE valami miatt újratöltéskor leszarja.



  2. #2
    nimda AlBrown logója
    Csatlakozott
    07-06-15
    Hely
    Budapest
    Hozzászólás
    405
    Begyűjtött 9 köszönetet
    6 hozzászólásával

    Alapbeállítás re: css gond

    Szerintem mindenek előtt rakd rendbe a HTML kódot, szvsz a hiba nem a CSS-ben van.

    1) 4. és 8. és 31. sorban furcsaságok vannak, felesleges nemLátható karakterek
    2) hiányzó <html> (lezároja ott van a végén )
    3) ez tuti nem számít, csak nem elegáns, hogy a headben vegyesen használód a lezárókat ( /> és valahol nincs) pl a DESCRIPTION és a KEYWORDS-nél pont nincs.

    így elsőre ezeket láttam, de érdemes ezekkel kezdeni



  3. #3
    Szerkesztő melon logója
    Csatlakozott
    08-03-18
    Hozzászólás
    267
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: css gond

    Igen, fontos, hogy legalább a dokumentum alap szerkezete legyen érvényes html. Ha az elején megadtad a DTD-ben, hogy HTML 4.01 Transitional, akkor ne használj önmagát lezáró tag-eket, mert az csak az XHTML-nél van tudomásom szerint. Esetleg próbáld meg a stíluslapot így behúzni:
    HTML kód:
    <style type="text/css" media="screen">@import "style.css";</style>
    , hátha ezt jobban szereti az IE7, de először is mindenképp javítsd a hibákat, nagyon valószínű, hogy rontja a böngésző esélyeit a hibás kód.



  4. #4
    Mentor Zaphod logója
    Csatlakozott
    08-01-21
    Hely
    Veszprém
    Hozzászólás
    324
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: css gond

    Köszönöm az ötleteket, valóban lemarad a <html> ez igen nagy szégyen rám nézve, illetve valóban XHTML lezárókat használtam HTML 4.01-nél. Ez is gáz Rendberaktam őket, de egy fikarsznyi hatással nem voltak a gondra.

    Aztán betettem a style-t, ahogy melon mondta. A gondot elfújta a szél. Megoldódott. Thx melon, az életben nem gondoltam volna rá.

    viszont, hogy a kód elejére honnan került az a pár pont. arról halvány segéd fogalmam sincs. Átrágtam az összes include-olt php forrást, de nincs felesleges pont. érdekes.



  5. #5
    Mentor Zaphod logója
    Csatlakozott
    08-01-21
    Hely
    Veszprém
    Hozzászólás
    324
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: css gond

    Idézet melon eredeti hozzászólása Hozzászólás megtekintése
    Igen, fontos, hogy legalább a dokumentum alap szerkezete legyen érvényes html. Ha az elején megadtad a DTD-ben, hogy HTML 4.01 Transitional, akkor ne használj önmagát lezáró tag-eket, mert az csak az XHTML-nél van tudomásom szerint. Esetleg próbáld meg a stíluslapot így behúzni:
    HTML kód:
    <style type="text/css" media="screen">@import "style.css";</style>
    , hátha ezt jobban szereti az IE7, de először is mindenképp javítsd a hibákat, nagyon valószínű, hogy rontja a böngésző esélyeit a hibás kód.
    micsoda baromság:
    ,,Másoknak is kell hírnévpontokat adnia, mielőtt melon hírnevéhez hozzáad,,.

    amitn engedi, szalad a pont. mégegyszer köszönöm



  6. #6
    Szerkesztő melon logója
    Csatlakozott
    08-03-18
    Hozzászólás
    267
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: css gond

    Ugyan már, örülünk, hogy bejött a tipp



  7. #7
    Új tag
    Csatlakozott
    08-10-19
    Hozzászólás
    14
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: css gond

    -töröltem az eredeti hozzászólást, tévedésből írtam ide-


    Utoljára módosítva: hungeri által : 2008-10-19 02:33 Oka: hülye vagyok és nem ide akartam írni...

A téma címkéi:

Könyvjelzők

Hozzászólás szabályai

  • Új témákat nem hozhatsz létre
  • Válaszokat nem küldhetsz
  • Fájlokat nem csatolhatsz
  • A hozzászólásaidat nem módosíthatod
  •