Eredmény: 1 - 9 (9) összesen

Téma: Css IE probléma

  1. #1
    Boy
    Boy nem elérhető
    Új tag
    Csatlakozott
    11-01-04
    Hozzászólás
    11
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás Css IE probléma

    Sziasztok!

    Seghítségetek kérném:
    Weboldalam menüsávjában lévő új oldalra irányító url-ek IE-ben nem működnek helyesen. Mit kellene módosítani ahhoz, hogy ugyanúgy működjön mint pl. firefox alatt? (hideg-burkolo-boy.hu)



  2. #2
    Bölcs Bruk logója
    Csatlakozott
    12-04-06
    Hozzászólás
    695
    Begyűjtött 251 köszönetet
    184 hozzászólásával

    Alapbeállítás re: Css IE probléma

    Hogy érted, hogy helyesen? Nem látom mi a helyes.

    OFF:

    Nem rosszindulatból írom, de ezzel a weboldallal az életbe nem szerzel megrendelőt. Bízz meg egy szakembert a weboldalad elkészítéséhez, mert egyértelműen látszik, hogy ez nem a te szakterületed. Olyan, mintha a webdesigner mindenféle előismeret nélkül leállna burkolni. Ha nincs kereted rá, akkor inkább tegyél fel a wordpresst, vannak hozzá elfogadható ingyenes sablonok, de a prémium sablonok is nevetséges áron kaphatóak. Így kevesebb szenvedéssel ingyen vagy minimális áron lesz egy pofás kis honlapod, amit az érdeklődők is komolyan fognak venni.


    JUST A DESIGNER | DRIBBBLE | BEHANCE

  3. #3
    Mentor
    Csatlakozott
    13-06-13
    Hely
    Pécs
    Hozzászólás
    431
    Begyűjtött 98 köszönetet
    79 hozzászólásával

    Alapbeállítás re: Css IE probléma

    Nálam látszólag minden rendben van. Esetleg leírhatnád valamelyik konkrét menüpont nevét, illetve, hogy melyik IE-t használod, mert lehet, hogy csak valamelyik régebbivel jelentkezik a gond.



  4. #4
    Boy
    Boy nem elérhető
    Új tag
    Csatlakozott
    11-01-04
    Hozzászólás
    11
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Css IE probléma

    Kedves Mentor!

    Igen jól látod. Valóban a kútfőmből ennyire tellett, de azért ez talán több a semmi nél!



  5. #5
    Boy
    Boy nem elérhető
    Új tag
    Csatlakozott
    11-01-04
    Hozzászólás
    11
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Css IE probléma

    Régebbi IE-t van fenn a gépemen. Nálam egyedül az okozza a problémát (Bruk hozzászólásával ellentében), hogy IE alatt a főoldalon bejövő menüs részre (mozgó kép alatt) ha lapozni a karok a témák között nem ugrik be a linken szereplő oldal. Az első menüpont (fürdőszoba) úgy van készítve hogy marad a főoldalon, míg a többi menű alatt (pl:terasz) át kellene mernnie a megadott url-re. Nálam ez nem működik. De köszi Petyyy a tippet, megnézem még más gépeken hogyan jön be, mert ha valóban csak a régi IE hozza ki rosszul, akkor nem fog érdekelni a probléma tovább!



  6. #6
    Adminisztrátor BagiZoli logója
    Csatlakozott
    07-04-26
    Hely
    8200, Királynék városa
    Hozzászólás
    3.855
    Begyűjtött 320 köszönetet
    154 hozzászólásával

    Alapbeállítás re: Css IE probléma

    Nekem az ie alatt a kompatibilitás nézetben jön elő a probléma. Ebben a módban régebbi webes technológiáknak megfelelő renderelés történik, ami már nem fut hiba nélkül az alkalmazott javascript funkciókkal. Prábáld ki azt, hogy az alábbi kódot beilleszted legelső meta tagnak.


    <meta http-equiv="X-UA-Compatible" content="IE=Edge" />



  7. #7
    Boy
    Boy nem elérhető
    Új tag
    Csatlakozott
    11-01-04
    Hozzászólás
    11
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Css IE probléma

    Beillesztettem a kódot legelső tagnak, de nálam a régi IE alatt továbbra is fenn áll a probléma. Időközben megnéztem az oldal működését más gépeken (újabb verzióju IE alatt, tableten, stb. ott nem tapasztaltam ilyen problémát.



  8. #8
    Szerkesztő
    Csatlakozott
    09-04-06
    Hozzászólás
    274
    Begyűjtött 23 köszönetet
    21 hozzászólásával

    Alapbeállítás re: Css IE probléma

    Én arra tippelnék, hogy itt az Ajax requestek miatt minden tabot megfog a script, kivétel 1-2 tabnál, de ez nincs IE8/7 alatt megoldva valamiért és ezért hal el (üres tartalom).

    szerk* kódba nézve: be van rakva a tabos .click()-ben egy return false, azt át kellene gondolni


    Utoljára módosítva: Deviant által : 2013-12-30 19:20

  9. #9
    Boy
    Boy nem elérhető
    Új tag
    Csatlakozott
    11-01-04
    Hozzászólás
    11
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: Css IE probléma

    Ezekbe a kódokba nem merek bele piszkálni amíg nem tudom mit okoz, mert az hogy üres lap jön elő egy egyszerű fülön megjelenő linket követve az egy alap struktúra. Ezt úgy értem ha megnézed a fürdőszoba fülre nyomva a főoldal url-t nem haggya el csak egy új lapot jelenít meg. Eredetileg az összes fülön így működött a link de ezt változtattam meg a többinél és csak a régi IE. nem tudja kezelni ezt a megoldást. Valamijen + kód beillesztésével lehetne ezt is megoldani amivel az IE felé jelzi rendesen az utat.



Könyvjelzők

Hozzászólás szabályai

  • Új témákat nem hozhatsz létre
  • Válaszokat nem küldhetsz
  • Fájlokat nem csatolhatsz
  • A hozzászólásaidat nem módosíthatod
  •