Oldal: 1 / 2 12 UtolsóUtolsó
Eredmény: 1 - 10 (13) összesen

Téma: ismeretlen futásidejű hiba

  1. #1
    Mentor Zaphod logója
    Csatlakozott
    08-01-21
    Hely
    Veszprém
    Hozzászólás
    324
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás ismeretlen futásidejű hiba



    van egy AJAX loader scriptem, az első félig meddig saját fejlesztés. Az Operán kívül mindenhol tökéletesen működik, nagyon rugalmasan használható. Konkrétan arra való, hogy egy az oldalon elhelyezett (általában hidden) div tartalmába betölt egy paraméterezett php programot. Használható sokmindenre (guestbook bejegyzés, oldalajánló, szavazás, stb...) nagyon szépen működik is. A mai honlapkritizálásra szánt oldalamban (www.ruhaszalon.hu) is használom elég sok helyen, többek közt a kiemelt hírek címére kattintáskor megjeleníti egy div-ben a tartalmat. Szuper. Csak nem IE-ben Ezerszer használtam már erre, minden gond nélkül, viszont most kis sárga felkiáltójellel lehal a script, merthogy: Ismeretlen futásidejű hiba. Megkérdeztem pár kolegát, de még csak nem is hallottak róla. A script természetesen a többi oldalrészben kiválóan működik, sőt, FF, Safari esetében ott is, ahol az IE-nél nem.

    Mi a retek ez az ismeretlen futásidejű hiba????

    ha az segít, bemásolom az ajax kódot.



  2. #2
    nimda AlBrown logója
    Csatlakozott
    07-06-15
    Hely
    Budapest
    Hozzászólás
    405
    Begyűjtött 9 köszönetet
    6 hozzászólásával

    Alapbeállítás re: ismeretlen futásidejű hiba

    idézek a kódodból:

    HTML kód:
    Meglepetés SZOMBAT</a></marquee>
    </div>
    </td></tr><div id="one_hir" style="display:none;"></div>
    		<tr><td align="center" colspan="2" bgcolor="#ffea98" height="30" valign="middle">
    ez így nagyon nem OK. Elvi hiba van benne, a ...</tr><tr>.... közé ha beteszed a DIV et, az furi
    legyen ilyen pl (persze rossz helyre fogja tenni, de innen már úgyis tudod mi a pálya):

    HTML kód:
    Meglepetés SZOMBAT</a></marquee>
    </div>
    <div id="one_hir" style="display:none;"></div>
    </td></tr>
    		<tr><td align="center" colspan="2" bgcolor="#ffea98" height="30" valign="middle">
    szvsz érdemes az ilyen X aktáknál átnézni a lapot előszőr w3c szempontból, mármint, hogy valid-e a HTML, mert sok fejtöréstől megkíméli az embert.



  3. #3
    Mentor Zaphod logója
    Csatlakozott
    08-01-21
    Hely
    Veszprém
    Hozzászólás
    324
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: ismeretlen futásidejű hiba

    Köszönöm. Igen. most reggel ahogy megnéztem a bejegyzésedet rájöttem, hogy már egyszer csinált velem ilyen az IE. A <table></table> -n belül kellett elhelyeznem a <div>-et, mert egyébként nem működöt.

    Megmondom őszintén egy időben állandóan W3C alapján utómunkáztam a kódot. Nagyon sok dolgot már most eleve aszerint csinálok. De egy idő után azt modtam, hogy a f..szom. Kit érdekel ez? Egy csomó plusz munka, egy csomó megkötés, stb... Ahogy látom ismét neki kell feküdni.

    Viszont 2 dolgot még továbbra sem tudok.
    1. Miért csak a szabványkövetéséről nem igazán híres IE akadt ettől le? a FF, Safari miért nem?
    2. Mi a retek az az ismeretlen futásidejű hiba, és hogy okozhatja ezt az, hogy a div a tr-n kívül van?

    Nagyon köszönöm a segítségedet.



  4. #4
    nimda AlBrown logója
    Csatlakozott
    07-06-15
    Hely
    Budapest
    Hozzászólás
    405
    Begyűjtött 9 köszönetet
    6 hozzászólásával

    Alapbeállítás re: ismeretlen futásidejű hiba

    nm
    szvsz ennél az esetnél, belül csak annyi lehet, hogy az IE nem találja meg a megfelelő node-ot, és nem tudja hova tegye be a divet az IE által írt hibaüzik, pedig nem túl beszédesek



  5. #5
    Mentor Zaphod logója
    Csatlakozott
    08-01-21
    Hely
    Veszprém
    Hozzászólás
    324
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: ismeretlen futásidejű hiba

    na igen. ezen gondolkoztam én is. mármint hogy nem tudja hová tegye. a csavar az a dologban, hogy ez épp egy abszolút poziciónálású div. ergo tök mindegy (elvileg) hogy a kódban hová teszem. Azt kell gondoljam, hogy az IE6teljesen egyedi módon értelmezi a kódokat néha. néha meg teljesen jól. ez katasztrófa.



  6. #6
    ingyenfreg mza8202 logója
    Csatlakozott
    07-10-18
    Hely
    Budapest
    Hozzászólás
    167
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: ismeretlen futásidejű hiba

    hmm...van itt mas problema is. pl hasznalsz egy scrollObject-et
    hivatkozol erre az objektumra,
    "window onloadban scroll1.scroll();"
    de nem peldanyositod a scroll1-et a scrollObject-bol.

    ez nemcsak ie-ben ad hibat, ff-ben is.

    a masik hiba pedig a chromeban van. nemtom hogy te irtad at e, de elegge kusza nekem:

    Kód:
    <script type="text/javascript">cssdropdown.startchrome("chromemenu")</script>
    meghivod ezt a fgv-t, ezzel a parammal, ami elvileg egy container id kell hogy legyen, aminek a childnodejaiban keresi meg az "a" kat.
    viszont a chrome objektumaban ennek a fgvnek nincs is paramja, nem is ertem mi akar ez lenni.

    ie6, ie7, ff-ben max par fgv, tulajdonsag, ill node nem ugyanugy van implementalva, ezek a hibak amik nalad vannak,
    ettol fuggetlenek legalabbis 5 perc utan ranezesre

    javaslom nezd at rendesen. jo munkat


    Utoljára módosítva: mza8202 által : 2008-01-30 20:51

  7. #7
    ingyenfreg mza8202 logója
    Csatlakozott
    07-10-18
    Hely
    Budapest
    Hozzászólás
    167
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: ismeretlen futásidejű hiba

    ja, ha mar mondom, akkor ide irom ezt is, lattam meg egy kis aprosagot, a kepek arnyeka css, ffben nem jo.



  8. #8
    Mentor Zaphod logója
    Csatlakozott
    08-01-21
    Hely
    Veszprém
    Hozzászólás
    324
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: ismeretlen futásidejű hiba

    Idézet mza8202 eredeti hozzászólása Hozzászólás megtekintése
    hmm...van itt mas problema is. pl hasznalsz egy scrollObject-et
    hivatkozol erre az objektumra,
    "window onloadban scroll1.scroll();"
    de nem peldanyositod a scroll1-et a scrollObject-bol.

    ez nemcsak ie-ben ad hibat, ff-ben is.

    a masik hiba pedig a chromeban van. nemtom hogy te irtad at e, de elegge kusza nekem:

    Kód:
    <script type="text/javascript">cssdropdown.startchrome("chromemenu")</script>
    meghivod ezt a fgv-t, ezzel a parammal, ami elvileg egy container id kell hogy legyen, aminek a childnodejaiban keresi meg az "a" kat.
    viszont a chrome objektumaban ennek a fgvnek nincs is paramja, nem is ertem mi akar ez lenni.

    ie6, ie7, ff-ben max par fgv, tulajdonsag, ill node nem ugyanugy van implementalva, ezek a hibak amik nalad vannak,
    ettol fuggetlenek legalabbis 5 perc utan ranezesre

    javaslom nezd at rendesen. jo munkat
    A chrome-ot nem én írtam. Nem csak elvileg, de gyakorlatilag is egy div ID-t keres, amit meg is talál.
    Kód:
    <div class="chromestyle" id="chromemenu"><a href="#" rel="hitel">tippek,tanácsok</a>
    a chromestyle class és a chromestyle id css-ben definiálva van, maga rel pedig itt:
    Kód:
    <div id="hitel" class="dropmenudiv">
    <a href="#" onmouseover="mutat(\'nagytipp\'), load(\'tippmutat.php?id='.$tipp['id'].'\',\'nagytipp\');" onmouseout="rejt(\'nagytipp\');">'.$tipp['cim'].'</a>
    </div>
    ezeket php generálja adatbázis tartalomból.

    a scroll object már kicsit kuszább valóban. Ennek a scroll1 változónak a létrehozása egy php által generált tömbből történik, aminek a tartalma persze mysql db-ből jön. Nincs kizárva, hogy némelyik paraméterének nem ad a php értéket. Átnézem. Köszönöm.



  9. #9
    Mentor Zaphod logója
    Csatlakozott
    08-01-21
    Hely
    Veszprém
    Hozzászólás
    324
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: ismeretlen futásidejű hiba

    Idézet mza8202 eredeti hozzászólása Hozzászólás megtekintése
    ja, ha mar mondom, akkor ide irom ezt is, lattam meg egy kis aprosagot, a kepek arnyeka css, ffben nem jo.
    Sajnos. de hát nem várhatjuk a ff-tól, hogy támogasson egy MS effektet Azért használom, mert a látogatók többsége mégiscsak IE és ott van árnyék. Ha tudsz valami (legalább ilyen minőségű) megoldást ami crossbrowser, azt igen megköszönöm.



  10. #10
    ingyenfreg mza8202 logója
    Csatlakozott
    07-10-18
    Hely
    Budapest
    Hozzászólás
    167
    Begyűjtött 0 köszönetet
    0 hozzászólásával

    Alapbeállítás re: ismeretlen futásidejű hiba

    erre leginkabb szep megoldast szerintem egy atlatszo png-s megvalositassal lehetne eszkozolni

    pl ezen az oldalamon van kerete a kepeknek, az valojaban csak egy atlatszo kep, ami letakarja a sarkait

    vagy mondjuk beraksz hasonlokepen a kepnek vmi hatteret es arra rakod ra
    a szocs egy regebbi oldalam, ott meg hatternek volt az atlatszo png-s hatter.

    sok megoldas lehet. esetleg csinalsz egy 60/70es opacity-s divet, amit meg tudsz css-sel oldani ffben, es ie-ben is, es azt rakod be a kep hatterenek, persze csusztatva, arnyeknak az is elmegy.


    Utoljára módosítva: mza8202 által : 2008-02-01 21:45

Oldal: 1 / 2 12 UtolsóUtolsó

A téma címkéi:

Könyvjelzők

Hozzászólás szabályai

  • Új témákat nem hozhatsz létre
  • Válaszokat nem küldhetsz
  • Fájlokat nem csatolhatsz
  • A hozzászólásaidat nem módosíthatod
  •