Eredmény: 1 - 8 (8) összesen

Téma: A post-ok első képét nem jeleníti meg a WP, mi lehet a baj?

  1. #1
    Mentor szabi logója
    Csatlakozott
    09-10-15
    Hely
    Budapest
    Hozzászólás
    357
    Thanked 1 Time in 1 Post

    Alapbeállítás A post-ok első képét nem jeleníti meg a WP, mi lehet a baj?

    Sziasztok, egy olyan problémám lenne Word Press-ben, hogy minden bejegyzés első képét nem igazán szereti megjeleníteni.

    Konkrétan ha feltöltök mondjuk 10 képet, az első kép után beteszem, hogy "more" , akkor az első kép aminek láthatónak kéne lennie mondjuk a főoldalon, az nem jelenik meg hanem csak a file név jelenik meg, és egy olyan linkre mutat amin nincs is tartalom.

    Pl. ez egy olyan link ami nem jó :

    vankepunk.hu/page/wp-content/upload/2009/09/mercedes_kepek1.jpg

    Annyira már rájöttem, hogy a "page" nem kellene bele, mert azok amik működnek így néznek ki:

    vankepunk.hu/wp-content/uploads/2009/09/mercedes_kepek3.jpg

    Van valakinek valami ötlete, hogy miképp lehetne ezt megoldani?

    előre is köszönöm



  2. #2
    WordPress Maniac mahone logója
    Csatlakozott
    08-08-22
    Hely
    Budapest
    Hozzászólás
    4.609
    Begyűjtött 248 köszönetet
    169 hozzászólásával

    Alapbeállítás re: A post-ok első képét nem jeleníti meg a WP, mi lehet a baj?

    A more tag után tedd az első képet. Úgy tudom az előtte lévő rész nem képes megbírkózni ezzel a feladattal.

    Ha mindenképpen kell a kép is a bevezető, akkor várj a további válaszra, biztos lesz, aki tud megoldást rá. Addig tedd át a képet a more után.



  3. #3
    Mentor szabi logója
    Csatlakozott
    09-10-15
    Hely
    Budapest
    Hozzászólás
    357
    Thanked 1 Time in 1 Post

    Alapbeállítás re: A post-ok első képét nem jeleníti meg a WP, mi lehet a baj?

    Számomra azért érthetetlen a dolog, mert ugyanakkor néhány post esetében viszont probléma nélkül működik. Viszont az első kép, mégha látszik is a more tag előtt, akkor a tovább katt után sohasem látszik...



  4. #4
    Buherátor Chati logója
    Csatlakozott
    07-12-03
    Hely
    Mohács
    Hozzászólás
    3.303
    Begyűjtött 267 köszönetet
    135 hozzászólásával

    Alapbeállítás re: A post-ok első képét nem jeleníti meg a WP, mi lehet a baj?

    Én használok olyat, hogy kép a more előtt és hibátlanul működik...
    Próbáld meg úgy, hogy a bejegyzést html módban szerkesztve átírod a kép linkjét...


    Nincs mit megmutatnom...

  5. #5
    Cartman, the Drummer AnagyZ logója
    Csatlakozott
    08-07-31
    Hely
    London - Dunaújváros
    Hozzászólás
    1.695
    Begyűjtött 12 köszönetet
    10 hozzászólásával

    Alapbeállítás re: A post-ok első képét nem jeleníti meg a WP, mi lehet a baj?

    vagy saját mezőt kell csinálni neki. a kivonatolás hogyan történik
    mert a the_content() meghagyja a képet ha a more tag előtt van és elméletileg akkor a teljes szövegnél is ott van.

    a the_excerpt() függvénynél nem jelenít meg a kivonatolás után képet de egy változó beiktatásával lehet rajta húzni egyet.

    modjuk ha megírnád a téma nevét vagy az oldalad pl www nélkül lehet többet látnánk
    mint így általánosan, mert ezt a codexből is ki lehet nézegetni



  6. #6
    Mentor szabi logója
    Csatlakozott
    09-10-15
    Hely
    Budapest
    Hozzászólás
    357
    Thanked 1 Time in 1 Post

    Alapbeállítás re: A post-ok első képét nem jeleníti meg a WP, mi lehet a baj?

    Igen, valóban ezzel is kezdhettem volna

    Tehát itt egy link, amin egyből a lap alján van 3 ilyen is : vankepunk.hu/tag/autos-kepek/page/2/ . A novitec ferraris, direkt nem mutat sehova, az is egy próbálkozás része volt.



  7. #7
    Mentor szabi logója
    Csatlakozott
    09-10-15
    Hely
    Budapest
    Hozzászólás
    357
    Thanked 1 Time in 1 Post

    Alapbeállítás re: A post-ok első képét nem jeleníti meg a WP, mi lehet a baj?

    Idézet Chati eredeti hozzászólása Hozzászólás megtekintése
    Én használok olyat, hogy kép a more előtt és hibátlanul működik...
    Próbáld meg úgy, hogy a bejegyzést html módban szerkesztve átírod a kép linkjét...
    Próbáltam, de abban még nincs benne a /page/ , vagy mást kéne módosítani?



  8. #8
    Mentor szabi logója
    Csatlakozott
    09-10-15
    Hely
    Budapest
    Hozzászólás
    357
    Thanked 1 Time in 1 Post

    Alapbeállítás re: A post-ok első képét nem jeleníti meg a WP, mi lehet a baj?

    Na szerencsére megoldódott a probléma, egy harmadik variációval .

    Azért köszönöm a válaszokat.



A téma címkéi:

Könyvjelzők

Hozzászólás szabályai

  • Új témákat nem hozhatsz létre
  • Válaszokat nem küldhetsz
  • Fájlokat nem csatolhatsz
  • A hozzászólásaidat nem módosíthatod
  •